Page 1 of 1

Electrical Gremlins

PostPosted: Sat Sep 16, 2017 1:24 pm
by Mick75
Hi
I have an '88 SR41B 750 that has developed a strange electrical issue, before I pull it apart someone might be able to save me some time, the bike starts easily and drives well with plenty of power it idles well at the lights, however if I use the indicators it cuts out and is difficult to restart I have to leave it sit for a few minutes then it restarts and runs fine same goes if I turn on the lights the battery is good as its plugged into a trickle charger when parked, the loom looks to be in good nick with no balls of insulating tape, I know its nearly 30 years old but any tips much appreciated

Re: Electrical Gremlins

PostPosted: Sat Sep 16, 2017 8:08 pm
by BigBob
Change the fuse as it may be getting overloaded.
It`s possible a wire is incorrectly connected and power is going to earth.

Re: Electrical Gremlins

PostPosted: Mon Sep 18, 2017 8:40 pm
by spendango
cut off the indicators :tup:

Re: Electrical Gremlins

PostPosted: Mon Sep 18, 2017 9:14 pm
by Mick75
That thought had crossed my mind.....

Re: Electrical Gremlins

PostPosted: Wed Sep 20, 2017 10:20 pm
by nug
A weird one for sure.Could be anything. The ignition is self energising on the Big so its unusual to have something outside effect it. It could be a dodgy ignition switch perhaps? Maybe the extra load of using the indicators is somehow giving a return to earth which would kill the ignition?

Re: Electrical Gremlins

PostPosted: Thu Sep 21, 2017 8:24 am
by BigBob
Disconnect all the indicators and while the bike is running reconnect them one by one to find out which one is at fault.
If the bike cuts out with any or all indicators connected, then check the indicator relay, which may be a Chinese shite replacement which has sh it itself.
Next step would be to check out the switch which could be earthing out
The ignition switch on these is prone to failure with age but I can`t see that it`s at fault on this one.
Other than that check the wiring behind the headlight for an incorrect connection
Wiring diagram here viewtopic.php?f=9&t=2224

Re: Electrical Gremlins

PostPosted: Thu Sep 21, 2017 4:44 pm
by Mick75
Thanks for the advice, I'll have a go at it over the weekend, have downloaded the manual and a colour wiring diagram from here, great resource

Re: Electrical Gremlins

PostPosted: Fri Sep 22, 2017 7:52 pm
by Mick75
Got home early today so had a go at the bike,on the green ignition plug on the loom side I found the red (main feed) and orange (switched feed) damaged, both wires are melted together with the copper exposed, so as I see it its either
A) the ignition switch is shagged and a poor connection overload the cables,although the switch bells out ok
B) the cables were crushed by the lockstop and short circuited
C)there's a earth fault causing a overload
D)all of the above
Either way I think Robinsons are getting more of my money
And who in the hell at Suzuki thought putting a big ball of cables above the front wheel was a good idea, that's the sort of thing you'd expect from the Italians

Re: Electrical Gremlins

PostPosted: Fri Sep 22, 2017 11:11 pm
by BigBob
You are going to have to repair the loom as new ones are not available any more. They were over £300 when available :o
You can buy the appropriate green connector on Ebay for a couple of quid.
New ignition switch from Suzuki is £83, though this one is the same with slightly shorter wires http://www.ebay.co.uk/itm/Ignition-Swit ... Swe-FU2jre
If it`s any help, 99% of Suzuki electrical problems are down to bad or no earth, so follow that direction first.